最近多次遇到这个问题,node16+版本安装或者初始化带有node-sass和sass-loader包的项目报错。翻遍了所有相关文章,总结出以下两种解决办法:

方法一:

卸载旧版本的node-sass和sass-loader,安装sass和sass-loader,不再使用node-sass

npm uninstall sass-loader node-sass
npm install sass-loader@8.0.2 sass@1.26.5 -D
方法二:

安装node16+相对应版本的node-sass和sass-loader

npm i node-sass@6.0.1 sass-loader@10.2.0
如果使用方法二之后报错,可能是安装过程中某些包丢失,尝试以下方法解决:

npm rebuild node-sass
————————————————

                        版权声明:本文为博主原创文章,遵循 CC 4.0 BY-SA 版权协议,转载请附上原文出处链接和本声明。

原文链接:https://blog.csdn.net/qq_17395607/article/details/126069258

By lxcss

发表评论

您的电子邮箱地址不会被公开。 必填项已用*标注